Windows 7 slow Internet

I have been having problems with a slow Internet connection.  Therefore, I decided to look online for a possible solution.  Unfortunately, I have not been able to find one.  Therefore, I decided to tinker on my own.

My router can be accessed through an Internet Browser.  Therefore, I decided to take a look at what can be changed there.

Looking at the settings, the top right corner has an option that I decided to try.  Reboot.

Beside the “System Has Been Up For”, the time was 416 hours.  After the Reboot, the time was resetted.

My Internet is running faster now.  Time will tell if it is the problem.  I am still  unsure if rebooting the router has fixed the problem.

Nov 8, 2011

It seems that the problem is the installed anti-virus program.  I decided to uninstall it and install Microsoft Security Essentials at http://windows.microsoft.com/en-CA/windows/products/security-essentials.

My computer had a few viruses that, fortunately, did not infect any Windows files.  Therefore, it does not seem that any damage was done.  In any case, the viruses seem to have entered through some Java security holes.  Therefore, I will have to determine which Java program they may have come from.

The problem has been solved.  It is unfortunate that I had to uninstall the anti-virus for another.  I really liked it.

Therefore, if you are having problems with slow Internet, uninstalling a 3rd party security program may solve the problem.

Ensure that Windows firewall is turned on while you determine if that 3rd party security program is really the problem.

Leave a Reply